Yarn学习笔记

技术

Yarn介绍

Yarn 是一个包管理器, 它允许你使用并分享代码给全世界的开发者, Yarn 做这些快捷、安全、可靠,所以你不用担心什么。
Yarn 允许你使用其他开发者的解决方案处理不同的问题,让你开发软件更容易。 如果你有疑问,你可以报告问题或者贡献回馈,当问题被修复时,你可以用 Yarn 让它们保持最新。
代码通过叫做 包(有时称为 模块) 的东西来共享。 包里包含所有要共享的代码,package.json 文件描述这个包。
ps:个人觉得其实就是FB公司订制版的npm,考虑到原版的npm设计有缺陷,FB对其进行了相关优化。具体哪里优化,我也不是很清楚。

安装

两种安装方式
1.官网推荐brew install yarn
2.npm全局安装 npm install -g yarn

使用 我会将yarn指令和npm指令进行对比

1.开始新项目

1
yarn init这里可以对照理解   npm init

2.添加依赖包

1
2
3
yarn add [package]                   npm install [package]
yarn add [package]@[version]
yarn add [package]@[tag]

3.升级依赖包

1
2
3
yarn upgrade [package]                      npm update [-g] [<pkg>...]
yarn upgrade [package]@[version]
yarn upgrade [package]@[tag]

4.移除依赖包

1
yarn remove [package]                         npm uninstall <package>

5.安装项目的全部依赖

1
yarn  或者 yarn install                        npm install

Yarn工作流

引入一个包管理器到你的项目也引入了一个新的围绕依赖的工作流。Yarn 尝试最好的保留你自己的方法并且让这个工作流的每一步理解简单。

  • 创建一个新项目
    yarn init其实就是创建package.json
  • 增加/更新/删除依赖

当你想添加、升级或移除依赖,你要了解几个不同的命令。
每个命令都会更新你的 package.json yarn.lock 文件。

  • 增加
1
2
3
4
5
6
7
8
9
yarn add [package]

你也可以用这些标记添加其它[依赖类型](https://yarnpkg.com/zh-Hans/docs/dependency-types):

yarn add --dev 添加到 devDependencies

yarn add --peer 添加到 peerDependencies

yarn add --optional 添加到 optionalDependencies

你可以通过指定一个依赖版本或一个标签来指定你想安装包的哪个版本。

1
2
yarn add [package]@[version]
yarn add [package]@[tag]
  • 升级依赖包
1
2
3
yarn upgrade [package]
yarn upgrade [package]@[version]
yarn upgrade [package]@[tag]
  • 移除依赖包
1
yarn remove [package]
  • 安装/重装你的依赖
    • 安装依赖项
1
yarn install 这条命令在执行后,yarn会从你的package.json读取依赖,然后安装,并存储到yarn.lock文件。
  • 安装选项

安装依赖有许多选项,包括:
安装所有依赖:yarn 或 yarn install
安装一个包的单一版本:yarn install –flat
强制重新下载所有包:yarn install –force
只安装生产环境依赖:yarn install –production

  • 和版本控制一起工作(例如 git)
    为了让人成功开发或使用你的包,你需要确保所有必要的文件提交进你的版本控制系统。
    为了别人能管理你的包,下面的文件必须提交进版本控制系统:
    • package.json:它有你的包当前所有依赖。
    • yarn.lock:这个存储你的包每个依赖的确切版本。
    • 为你的包提供功能的实际源代码。

本文作者:Konger

本文链接: https://blog.ninglans.top/posts/53289/

评论